Codinion

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Enhanced Syntax Highlighting
  • Priority Very Low
  • Reported Version 1.0.0.4950
  • Due in Version Undecided
  • Votes
  • Private
Attached to Project: Codinion
Opened by wmj - 16.09.2017
Last edited by Martin Topfstedt - 23.09.2017

FS#111 - Codinion is conflicting with VSColorOutput: Syntax highlighting -> Highlight search results

The "Highlight search results" function is conflicting with VSColorOutput, which also highlights the output window.

Reproduction:

1, Install VSColorOutput and Codinion.

2, Press Ctrl+H in the editor to display the search and replace dialog.

3, Hit the "Replace All" button to replace multiple text.

VS will crash after step 3.

Closed by  Martin Topfstedt
23.09.2017 14:35
Reason for closing:  Fixed
Additional comments about closing:  in 1.0.0.4982
Admin
Martin Topfstedt commented on 16.09.2017 11:48

Hi,

i tried to reproduce it but i can't get the crash. Could you try to find some log files?

And i guess you mean the "Find Results" window instead of the "Output" window right?

wmj commented on 17.09.2017 01:10

No log file was recorded at the crash.

You shall enable the "Colorize Find Results window" option to reproduce the crash.

Yep, I meant the "Find Results" window.

Admin
Martin Topfstedt commented on 20.09.2017 19:50

Hi,

i tried it again but no luck. Ctrl-H does not even open the "Find Results" Window, i guess something is missing here.

I attached a Version where i fixed the Peek Crash and i couldn't reproduce the bug. Can you please test if it still exists?

 

wmj commented on 21.09.2017 06:36

Hi,

Please use the Ctrl+Shift+H to open the dialog.

The searching scope should be "Entire solution".

When you perform the "Replace All" operation by hitting the corresponding button in that dialog, the "Replace all" window and the "Search Results" window will appear and VS will crash.

 

I'd just downloaded the new version. I tried several times and it seemed to be working just fine. I will report further problems when I encounter this issue again.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing