• Status Closed
  • Percent Complete
  • Task Type Bug Report
  • Category Enhanced Syntax Highlighting
  • Priority Very Low
  • Reported Version
  • Due in Version Undecided
  • Votes
  • Private
Attached to Project: Codinion
Opened by wmj - 08.11.2017
Last edited by Martin Topfstedt - 21.11.2017

FS#114 - Syntex highlighting could get broken after file rename

Open a code file.

Rename that file in the Solution Explorer.

The syntax highlight will get broken.

VS 2017 15.4

Closed by  Martin Topfstedt
21.11.2017 17:17
Reason for closing:  Fixed
Additional comments about closing:  in
wmj commented on 08.11.2017 00:33

It was quite weird that the above procedure could not reproduce the bug each time.

Sometimes it did, sometimes it didn't.

Martin Topfstedt commented on 11.11.2017 11:22


yes i already encountered that as well, but it is really hard to reproduce.

wmj commented on 17.11.2017 02:11

Currently the only wayout is to unload the solution.

At the moment while the syntax highlighting is broken, we are quite probably editing the code. Unloading the solution means throwing away all undo records in the editor, which might be quite undesirable.

Is it possible to provide a button to reset the highlight?

Martin Topfstedt commented on 21.11.2017 16:54

i try to find the bug and provide a hotfix.



Available keyboard shortcuts


Task Details

Task Editing