Codinion

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Enhanced Syntax Highlighting
  • Priority Very Low
  • Reported Version 1.0.0.3618 Beta
  • Due in Version Undecided
  • Votes
  • Private
Attached to Project: Codinion
Opened by wmj - 20.03.2016
Last edited by Martin Topfstedt - 10.05.2016

FS#45 - Syntax Highlight Is Not Applied to Newly Created Members In WinForm

There are two issues in the latest beta.

Reproduction:

1, Create a new WinForm project.
2, Add a control, for instance, a button named "button1", onto the Form from the designer.
3, Switch to the code view and type "button1" in the code window.
Issue 1: The "button1" will not be highlighted.
4, Type the following:

button1.Click +=

5, Press the Tab key on the keyboard to create the event handler for the Click event. VS will complete the code as:

button1.Click += Button1_Click;

And a method named "Button1_Click" will be created below.
Issue 2: "Button1_Click" on the above method is not highlighted.

Closed by  Martin Topfstedt
10.05.2016 19:09
Reason for closing:  Implemented
Additional comments about closing:  in 1.0.0.3867 Beta
wmj commented on 20.03.2016 11:42

A NullReferenceException also occurred after I closed the solution. Please check out the stack trace in the attached ActivityLog file.

Admin
Martin Topfstedt commented on 21.03.2016 09:41

Ok i guess i know the problem, the intermediate files are not created for a new project. Fixing this could take a while.

A workaround would be building the project and reopen it, than the intermediate .g.i.cs files are created in (obj/Debug) etc.

wmj commented on 21.03.2016 11:33

Actually, after saving the document, the highlight for those elements became normal.

The assumption that this issue has something to do with the intermediate files was questionable.
If it is because the saving of the document, why other fields, properties, methods that I typed into it could be correctly highlighted before saving, but those generated by the form designer and IDE were not?

wmj commented on 11.04.2016 04:06

It has been quite some time not having seen new updates of Codinion.
How are you doing Martin?
Is it possible to provide a menu item to force refresh the syntax highlight if the fix of this issue is tough?

Admin
Martin Topfstedt commented on 11.04.2016 05:43

Hi, i'm fine thanks for asking. I was sick and after that on vacation so i couldn't do anything on codinion. I will start today again and try to fix all bugs asap.

wmj commented on 13.04.2016 10:30

Sorry to hear that you've gotten sick.
Nice to hear that you are back and continue onto this great work :)

Admin
Martin Topfstedt commented on 17.04.2016 20:30

Hey, thanks. I found the problem. I have actually a file listener on the designer.cs file but if you don't save it i don't get any events that the file has been changed. If the designer.cs(Code) file is opened as tab everything works fine. I will look for a way to get the missing changes.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing