Codinion

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Enhanced Syntax Highlighting
  • Priority Very Low
  • Reported Version 1.0.0.3890 Beta
  • Due in Version Undecided
  • Votes
  • Private
Attached to Project: Codinion
Opened by Anonymous Submitter - 24.03.2016
Last edited by Martin Topfstedt - 02.06.2016

FS#50 - Messed syntax highlighting when reloading file changed elsewhere

I've noticed that, when reloading file, Enhanced Syntax Highlighting gets totally messed (as if it was based in line&column). It happens, for instance, when switching branches in Team Explorer and open files differ from one branch to the other one.

Closed by  Martin Topfstedt
02.06.2016 18:23
Reason for closing:  Fixed
Additional comments about closing:  in 1.0.0.3967 Beta
wmj commented on 11.04.2016 04:03

It was not so stable.
Sometimes no files were reloaded but the highlight still got messed up while I was typing XML comments or coding in the code document editor.

Admin
Martin Topfstedt commented on 12.04.2016 18:50

hmm is the codinion version here correct? I would say try the beta.

wmj commented on 13.04.2016 10:27

The new beta had this issue as well.
I could not reproduce it predictably at this moment.

wmj commented on 15.05.2016 07:32

The syntax highlight still somehow got messed up in the latest beta.
Is it possible to provide a menu item in the beta to manually refresh the highlight?

Admin
Martin Topfstedt commented on 26.05.2016 13:10

hi, usally it should work to just change the text again. I myself press enter if the highlighting is screwed up. But i don't think i will add a refresh button this would just hide the problem.

wmj commented on 30.05.2016 03:10

Yep, you are right. Pressing Enter could restore the highlighting, no need to add the Refresh button.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing